Random no longer random - V1.68 bug [fixed w/V1.70]

Questions and Answers concerning the spectralis!

Moderator: Jörg Schaaf

Random no longer random - V1.68 bug [fixed w/V1.70]

Postby acemonvw » Mon Feb 01, 2016 4:38 am

I'm using the Spectralis 2. I just updated to Version 1.68 yesterday. I was creating some new sequences and getting a handle on the new 'seq' lines for the DSP-synth, and set one of the sequences to random and noticed that the same notes started being modified every 16 steps.

Take any sequencerline, press random, then hit play, and watch this 'random' sequence (it may not start on '7', but you get the idea):

7, 8, 13, 6, 3, 4, 9, 2, 15, 16, 5, 14, 11, 12, 1, 10 repeating...

EDIT: resolved in firmware V1.70
Last edited by acemonvw on Mon Feb 08, 2016 1:25 pm, edited 2 times in total.
User avatar
acemonvw
 
Posts: 1200
Joined: Fri Mar 18, 2011 8:28 pm
Location: Minneapolis, MN

Re: Random no longer random - V1.68 bug

Postby acemonvw » Mon Feb 01, 2016 5:26 am

On a song that has 'random' sequencerlines previously, other strange behaviors are present. Certain steps are not even activated. With my song, steps 2, 4, 6, 7, and 16 will not even activate.

If I change the length of steps from 16 to 15, then some of these notes will activate.
Last edited by acemonvw on Mon Feb 01, 2016 2:11 pm, edited 2 times in total.
User avatar
acemonvw
 
Posts: 1200
Joined: Fri Mar 18, 2011 8:28 pm
Location: Minneapolis, MN

Re: Random no longer random - V1.68 bug

Postby Jörg Schaaf » Mon Feb 01, 2016 2:03 pm

Thanks for your bug report. Andreas will fix that this week.
New users please check the following link for forum activation:
http://www.forum.radikaltechnologies.com/viewtopic.php?f=8&t=921
http://www.myspace.com/jorgschaaf
http://www.youtube.com/user/SCHAAFJOERG
User avatar
Jörg Schaaf
 
Posts: 1096
Joined: Sat Aug 20, 2005 1:46 am
Location: Germany

Re: Random no longer random - V1.68 bug

Postby via » Mon Feb 01, 2016 2:42 pm

Nice bug catch  :wink:  ... I can confirm this, random seams to be playing a set pattern (although it has random playback, its still always the same) .. 
 
Another, when copying a sound via motif  
 
I select a drum sound and press motif to exchange "copy" the sound and motif with another track, all step parts lid up and now when I hit a part to exchange, it tells me there is a missing sounds and does not respond correctly.. it does work if I hit (NO) and select the sound from the Encoder from the screen ...  
 
I was getting other funky stuff.. One time all parts lid up except the kick, and at one time the hihat motif didn't copy correctly at first was not playing the correct drum notes, it then worked ..  
 
When exchanging Favorites on complete drum kits, sometimes the OHH will be the same sound ... It seams if you select kit 13 it will have the OHH from kit 13 on all other kits until you hit kit 3 then it will have the OHH of kit 3 on all parts until you hit kit 13 again and then your back to OHH of kit 13   
 
Now prior to 1.68 There was a motif exchange bug in 1.04 (it didn't find motifs on certain parts from patterns) .. And I did notice the drum kit bug on 1.04 but only like a week before we got this update  
 
Can anyone confirm these?
via
 
Posts: 702
Joined: Sat Aug 19, 2006 3:19 am

Re: Random no longer random - V1.68 bug

Postby via » Mon Feb 01, 2016 2:53 pm

When exchanging Favorites on complete drum kits, sometimes the OHH will be the same sound ... It seams if you select kit 13 it will have the OHH from kit 13 on all other kits until you hit kit 3 then it will have the OHH of kit 3 on all parts until you hit kit 13 again and then your back to OHH of kit 13   


I dont know if this will help but I think it's relevent ... The two OHH sound that seam to play through the Fav DRumkit selection are the only 3 OHH sound under Favorite OHH .. I have the same Ohat on step 1 and 2 (this is the one that plays thoughout all the kits when I hit Favorite Drumkit 3 .. The sound on Favorite OHH step 3, is the sound that plays throughout Favorite Drumkit when I press kit 13 ...
via
 
Posts: 702
Joined: Sat Aug 19, 2006 3:19 am

Re: Random no longer random - V1.68 bug

Postby Jörg Schaaf » Mon Feb 01, 2016 3:13 pm

Hmm - Maybe I forgot to define an OpHH sound in those drumkits. Do you tried to save your own favorite drumkit?
New users please check the following link for forum activation:
http://www.forum.radikaltechnologies.com/viewtopic.php?f=8&t=921
http://www.myspace.com/jorgschaaf
http://www.youtube.com/user/SCHAAFJOERG
User avatar
Jörg Schaaf
 
Posts: 1096
Joined: Sat Aug 20, 2005 1:46 am
Location: Germany

Re: Random no longer random - V1.68 bug

Postby via » Mon Feb 01, 2016 3:18 pm

I'm heading out, I'll test it tonight, I'll load diffrent OHH in the favorites and see if this bug continus in fav Drumkit with the new OH sounds..
via
 
Posts: 702
Joined: Sat Aug 19, 2006 3:19 am

Re: Random no longer random - V1.68 bug

Postby Jörg Schaaf » Mon Feb 01, 2016 3:21 pm

via wrote:Nice bug catch  :wink:  ... I can confirm this, random seams to be playing a set pattern (although it has random playback, its still always the same) .. 
 
Another, when copying a sound via motif  
 
I select a drum sound and press motif to exchange "copy" the sound and motif with another track, all step parts lid up and now when I hit a part to exchange, it tells me there is a missing sounds and does not respond correctly.. it does work if I hit (NO) and select the sound from the Encoder from the screen ...  
 
I was getting other funky stuff.. One time all parts lid up except the kick, and at one time the hihat motif didn't copy correctly at first was not playing the correct drum notes, it then worked ..  
 
When exchanging Favorites on complete drum kits, sometimes the OHH will be the same sound ... It seams if you select kit 13 it will have the OHH from kit 13 on all other kits until you hit kit 3 then it will have the OHH of kit 3 on all parts until you hit kit 13 again and then your back to OHH of kit 13   
 
Now prior to 1.68 There was a motif exchange bug in 1.04 (it didn't find motifs on certain parts from patterns) .. And I did notice the drum kit bug on 1.04 but only like a week before we got this update  
 
Can anyone confirm these?


Maybe you tried that with a song, that already uses the whole sample ram. In that case it won't load any new samples anymore. When you use the motiv exchange function, the part LEDs always show up, which parts of the selected pattern are offering motifs. When all LEDs are litting up this simply means, that you can gat a motiv from each parts because they all hold motiv data.

The Spectralis even converts motif data from DSP Synth parts, to make them usable for drumparts. If you for example want to double a bass motif of DSP synth 1 with a kick drum, just select the DSPSynth part 1 as the motiv source for the kickdrum. The Spectralis will than play the same rhythmic phrase like the bass but with a fixed pitch.
New users please check the following link for forum activation:
http://www.forum.radikaltechnologies.com/viewtopic.php?f=8&t=921
http://www.myspace.com/jorgschaaf
http://www.youtube.com/user/SCHAAFJOERG
User avatar
Jörg Schaaf
 
Posts: 1096
Joined: Sat Aug 20, 2005 1:46 am
Location: Germany

Re: Random no longer random - V1.68 bug

Postby via » Mon Feb 01, 2016 7:18 pm

OK about the drumkit ITS NOT A BUG ... Would you believe that all my fav drumkits except 3 and 13 had NO OH sound :shock: so this is why the OH did not change when selecting new kits  :oops:   :shock:  That was quite idiotic of me ... I mean who doesn't use OHHats in their kits on  the spectralis they sound so good  :wink:   

 
Now about the motif exchange .. There is definitely bugs here ... 
 
Ok first when you press motifs avalible  motifs parts  (steps) light up ... And before 1.68 I could just press these steps and get the motif (very nice workflow) and just to be clear when selecting the motifs via the encoders ala select the part via the LCD + encoders it Works!   Sure, no problem! .... but when you press the steps (that very nice workflow of touching the desired  motifs(steps) it's not functioning,  (motifs seams to not get the part right, you can press the step again and another motif part starts but not the right one (I can press a motif for tom but the kick motif drops in, I press tom again and Perc motif comes in , never does the tom (the right motif come in) BTW  the no sound thing was me not having my sd card in the slot) sorry about that but it rules out full memory..
 

Now I have the spectralis in front of my right now testing things, and a clap motif with irregular timing does not lid up as an available motif but it does though show up under encoder the LCD , now when I first copied it it was not playing right but after I repeated copy in was fine, so ok it works but its little funky, there was also an instant where a few parts did not show up as motifs under the encoder but when entering the pattern again they where, so funky times :wink:

 
But not being able to touch (copy) the motifs via steps was so nice and I believe you guys designed it this way .. I actually love this workflow and its the best I've ever seen or used (on other devices you need to scroll and select parts you want to copy and paste and sometimes stop the workflow .. On the spectralis it's always been instantaneous and You physically touch the tracks/motifs, this is also what makes FAVORITES such a wonderful function (I am so glad you guys added this workflow and I really hope you can apply this Favorite workflow to drum grooves and motif to capture and have instant access to your favorite motifs and drums ... It so joyfully to be able to instantly recall your favorite ideas  in this vast system   8) ;)
via
 
Posts: 702
Joined: Sat Aug 19, 2006 3:19 am

Re: Random no longer random - V1.68 bug

Postby Jörg Schaaf » Mon Feb 01, 2016 7:27 pm

Thanks for the hint. Andreas promised a new version for the end of the week. Hopefully all bugs will get fixed until then.
New users please check the following link for forum activation:
http://www.forum.radikaltechnologies.com/viewtopic.php?f=8&t=921
http://www.myspace.com/jorgschaaf
http://www.youtube.com/user/SCHAAFJOERG
User avatar
Jörg Schaaf
 
Posts: 1096
Joined: Sat Aug 20, 2005 1:46 am
Location: Germany

Next

Return to Helpdesk

Who is online

Users browsing this forum: No registered users and 1 guest

cron